This project has moved and is read-only. For the latest updates, please go here.

Win8 version install fail

Oct 4, 2011 at 4:51 PM


I was attempting to install the newly released version for win8 on the developer preview version of win8. When the console ModifyRegistryKey app runs, it errors out and the installation stalls. The console remains open with this error:

Syntax: ModifyRegistryKey [-i11u|-i11m|-i10u|-i10m|-i10x|-i08u|-i08m|-uu|-um] [p

Any ideas?



Oct 5, 2011 at 6:00 AM
Edited Oct 5, 2011 at 6:01 AM


I also have problems installing MVVM Light Toolkit for Windows 8. The setup fails and shows the following message: "There is a problem with the Windows Installer Package. A program required for this install to complete could not be ryn. Contact your support personnel or package vendor."

I'm installing MVVM Light Toolkit for Windows 8 on Windows 8 Developer Preview 64 bit that is running on Virtual Box 4.1.4.


Oct 5, 2011 at 9:14 PM

Quick update guys: The second issue (OasisLiveForever) was reported by a few people, and I am on it. It seems that there is an issue because the custom action is using .NET 4 and Windows 8 comes with .NET 4.5 only by default. It works on my machine because I also have VS10 installed side by side, and this installs .NET4.

The first issue (RodWatkins) is not something I have seen anyone else reporting. As soon as I have a fix for the second issue, I will pass the link to you guys for testing, and if it doesn't fix Rod's issue, I will work with you directly on that.


Oct 5, 2011 at 9:54 PM
Edited Oct 5, 2011 at 9:54 PM

OK can you guys please try this one:

I recompiled the custom action using .NET 4.5 which is installed by default in Windows 8. Please let me know if that solves your issues.

Thanks a lot for the help,

Oct 5, 2011 at 11:22 PM

Sorry, here is another update: I worked with Tim Heuer from Microsoft to find the cause of the issue, and it is not (as I first thought) due to the custom action, but rather to some missing keys in the registry when only VS11 Express is installed. I assume that you guys also have the "vanilla" package with only VS11 Express, and no VS11 Ultimate installed, is that right?

Ignore the previous message with the MSI, i will now make a VHD with a vanilla Win8 install and fix the MSI.



Oct 5, 2011 at 11:49 PM

Actually, I have the developer's preview of VS Ultimate installed (along side the express version) on my win8 machine. Are those keys still missing if you only have the 2011 versions installed?

A little manual fiddling bypassing the installer and I got everything up and running, but I'm sure you want the wrinkles in the installer fixed. I am not at my win8 machine now, but I'll try the new installer tonight and let you know if it solves the problem I had.


Oct 6, 2011 at 11:20 AM

Hi Rod,

After you try the Debug installer posted at the link above, can you please send me the file c:\temp\mvvmlightinstall.txt?

Thanks in advance,


Oct 6, 2011 at 4:43 PM

Huh, no change, same error. And oddly, there is no mvvmlightinstaller.txt in c:\temp. There's no c:\temp at all. I presume it crashing before the code to create the log.


Oct 6, 2011 at 5:08 PM

Hey Rod,

Are you on MSN or Skype? 


(Send per email to laurent at galasoft dot ch if you can)

Oct 7, 2011 at 4:30 AM

Hi Laurent,

I tried to install the debug version that you recompiled but I get the same error.
This is the content of the file C:\temp\mvvmlightinstall.txt

Starting install at 10/6/20118:25:54 PM
Args[0]: -i11m
Args[1]: C:\Program Files (x86)\Laurent Bugnion (GalaSoft)\Mvvm Light Toolkit\SnippetsWin8\;
Checking subKey Software\Microsoft\VisualStudio\11.0\Languages\CodeExpansions\CSharp\Paths in HKEY_LOCAL_MACHINE
subKey == null (Software\Microsoft\VisualStudio\11.0\Languages\CodeExpansions\CSharp\Paths)
Ending install at 10/6/20118:25:54 PM
Starting install at 10/6/20118:25:54 PM
Args[0]: -i11u
Args[1]: C:\Program Files (x86)\Laurent Bugnion (GalaSoft)\Mvvm Light Toolkit\SnippetsWin8\;
Checking subKey Software\Microsoft\VisualStudio\11.0\Languages\CodeExpansions\Visual C# in HKEY_CURRENT_USER
subKey == null (Software\Microsoft\VisualStudio\11.0\Languages\CodeExpansions\Visual C#)
Ending install at 10/6/20118:25:54 PM

Oct 7, 2011 at 6:07 AM


Thanks! in your case it is due to discrepancies between the VS11 and VS11 Express. I will publish today a page explaining how to manually install. I will also fix the installer for VS11 express, but that might take a little more time. Stay tuned to my blog (, I will publish when ready.

Thanks again,


Oct 8, 2011 at 2:22 PM

Hey guys,

Please try this installer, it should correct most (or all ;) errors 

Please let me know if it works (or not) ;)


Oct 9, 2011 at 5:46 AM

Hi Laurent,

the new version works great.

Thank you very much.

Oct 9, 2011 at 11:26 PM

Works like a charm now. Sorry for not responding sooner. It's Thanksgiving weekend here in Canada, so I've been busy (cooking, eating, watching hockey, eating again)!