encountering error with V3 installer.

Oct 5, 2011 at 10:39 PM
Edited Oct 5, 2011 at 10:41 PM

I just recently had to reimage my dev machine and so I need to install V3 of the MVVMLight toolkit.  I downloaded the new msi installer and attempt to use it.

I go through the wizard and life appears to be good....  It gets to the point where it is copying files and then after a few seconds gives the following error.

"There is a problem with this Windows Installer package.  A program required for this install to complete could not be run.  Contact your support personnel or package vendor."

I have both VS2008 and VS2010 SP1 installed on my machine.  The OS is Windows XP and all windows updates have been installed as well as all prerequisites listed for MVVMLight.  I am a local adminstrator on the box. 

Any suggestions on what is causing this error and how to resolve would be appreciated.

 

Thanks,

 

Brent

Oct 5, 2011 at 11:07 PM
Edited Oct 5, 2011 at 11:09 PM

Here is an update.... I should have looked in the event log before posting....

The problem appears to be that the path to the ModifyRegistryKey executable in the PostSetupAction contains spaces and has not been enclosed in quotes.

 

 


The description for Event ID ( 11721 ) in Source ( MsiInstaller ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Product: MVVM Light Toolkit -- Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor. Action: PostSetupActionVS08Machine, location: B:\, command: C:\Documents and Settings\broett01\Application Data\\MvvmLight\ModifyRegistryKey.exe -i08m "C:\Program Files\Laurent Bugnion (GalaSoft)\Mvvm Light Toolkit\Snippets\;B:\ , (NULL), (NULL), (NULL), (NULL), , .

 


Coordinator
Oct 6, 2011 at 10:16 AM

Hi,

So sorry about that. Thanks for the report. I will post an updated installer today.

Cheers,

Laurent

Coordinator
Oct 7, 2011 at 4:51 PM

Hi,

I posted an updated MSI where this small error is corrected. Can you try again? Simply download the MSI from the download section, replacing the one you had downloaded previously, and reinstall.

Thanks!

Laurent

Oct 7, 2011 at 5:50 PM

Laurent,

The new version of the installer works perfectly.  Thanks again for a great toolkit!

Cheers,

Brent

Aug 22, 2012 at 8:50 PM

I have very much the same (or similar) issue attempting to install V4.0.23.3 (July 29) on a Windows XP SP3 machine with both VS2005, VS2008, and VS2010. I downloaded V3 and it installed just fine, but it would seem that V4 suffers from the same fate as V3 did at the time of this original posting.

Here is the EventLog message:


The description for Event ID ( 11721 ) in Source ( MsiInstaller ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Product: MVVM Light Toolkit -- Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor. Action: PostSetupActionVS10Machine, location: C:\, command: C:\Documents and Settings\sjmartin\Application Data\\MvvmLight\ModifyRegistryKey.exe -i10m "C:\Program Files\Laurent Bugnion (GalaSoft)\Mvvm Light Toolkit\Snippets\CSharp\ , (NULL), (NULL), (NULL), (NULL), , .

Oct 10, 2012 at 7:49 PM
Edited Oct 10, 2012 at 8:16 PM

I get the same error when trying to install 4.0.23.4 on windows 7 with Visual Studio 2010 installed.

 

Product: MVVM Light Toolkit -- Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor. Action: PostRemoveActionMachine, location: C:\, command: C:\Users\Administrator\AppData\Roaming\\MvvmLight\ModifyRegistryKey.exe -um "C:\Program Files (x86)\Laurent Bugnion (GalaSoft)\Mvvm Light Toolkit\Snippets\;C:\Program Files (x86)\Microsoft Visual Studio 10.0\

 

UPDATE/FIXED

I think I fixed/worked around it. I turned out that "C:\Users\Administrator\AppData\Roaming\\MvvmLight\ModifyRegistryKey.exe" didn't exists. I created an empty console program with that name and put it in this position. Now I could uninstall an older version and install the newer. I probably also works when you directly install a new version.

Hope this will help someone else. :)

Oct 12, 2012 at 3:57 PM

I get the same problem:

Product: MVVM Light Toolkit -- Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor. Action: PostSetupActionVpdx10, location: E:\, command: C:\Users\Peter Shrosbree\AppData\Roaming\\MvvmLight\ModifyRegistryKey.exe -i10vpdx "C:\Program Files (x86)\Laurent Bugnion (GalaSoft)\Mvvm Light Toolkit\Snippets\CSharp\

 

Notice there is no closing quote.

I tried the workaround of creating the dummy ModifyRegistryKey.exe executable and placing it in the directory, but it had no effect.

Any suggestions?

 

 

 


Coordinator
Oct 12, 2012 at 5:10 PM

Hi,

Believe it or not, it is correct that the last quote should NOT be there, or else there are some issues in the MSI.

Please follow the steps to get me a log:

- Uninstall MVVM Light

- Create a folder named “mvvmlighttempo” in C:\

- Rerun the same installer

- Send me the file mvvmlightlog.txt located in that folder.

You can then delete the folder

Thanks in advance

Laurent

Jul 1, 2013 at 9:59 AM
Hi,

I am getting the same error with ModifyRegistry command. I'm on Windows 7 Professional, the error appairs for
  • 4.0.23.4 msi package
  • 4.1.24.0 msi package
Any suggestion?

Thanks in advance