MSI installer did not install templates or snippets

Jul 11, 2012 at 3:05 PM

I've just run the latest installer (GalaSoft.MvvmLight.4.0.23.1.msi), but no templates or snippets were installed.  Are templates/snippets an additional download?  I've used this product in the past and the installer would always install the templates.  Thanks in advance for any help!

Coordinator
Jul 11, 2012 at 3:15 PM

Hi,

Thanks for the report. I just need some more info.

  • What OS are you on? 
  • What version of Visual Studio do you try to install for?

Once I have this info, I will be able to help you more.

Cheers,

Laurent

Jul 11, 2012 at 3:23 PM

Hi Laurent.

Thanks for such a quick response, in fact I was just logging on to say that I jumped the gun...a little 'ReadMe' goes a long way!  I had not realized the templates were now installed via the Extension Manager.  Once I did that everything is fine.  Sorry for the false alarm!  Also let me say that this is an awesome product.  When I was on a big project with a major bank in 2010, we decided to try it to help us better understand MVVM, and I've never looked back, best decision we ever made.  I'm now directing another project with a fairly large production company and am pushing for its adoption.  Thanks again for such a rapid response.

Coordinator
Jul 11, 2012 at 3:36 PM

Happy to hear. I decided to switch to Extension Manager for templates indeed, because it just makes the installer so much faster and actually easier to test. I tried to make the readme as obnoxious as possible ;) 

Cheers,

Laurent

Coordinator
Jul 11, 2012 at 3:36 PM

Just to confirm, snippets are working?

Laurent

Jul 11, 2012 at 3:57 PM

Just tried to create a SL5 template app and get the following:

C:\Users\<myuserid>\AppData\Local\Temp\kfvgrr2b.red\Temp\MvvmLight2.csproj(125,3):  The imported project "C:\Program Files (x86)\MSBuild\Microsoft\Silverlight\v5.0\Microsoft.Silverlight.CSharp.targets" was not found.  Confirm that the path in the <Import> declaration is correct.

Jul 11, 2012 at 4:00 PM

Hang on, once again I might have jumped the gun...just realized this was on a test dev machine, and I didn't have SL5 installed.  Will install, test, and report back...

Coordinator
Jul 11, 2012 at 4:02 PM

I was just going to say, this error comes when SL5 is not installed on the target machine ;)

Cheers,

Laurent

Jul 11, 2012 at 4:28 PM

Ok, installed SL5 and it's all good.

One question, I had to manually move the snippets into ...\Visual Studio 2010\Code Snippets\Visual C#\My Code Snippets.  Is this expected or should the installer have done this?  But yes, they are working just fine.

Other than that, I'm golden, thanks again for your lightning fast support :)

Jul 11, 2012 at 7:34 PM
Edited Jul 11, 2012 at 7:35 PM

I try to install the templates for Visual C# 2010 Express and get the following error:

 

11.07.2012 21:32:22 - Er wird nach passenden Produkten gesucht...
11.07.2012 21:32:22 - Installiertes Produkt gefunden - Microsoft Visual Basic Express 2010
11.07.2012 21:32:22 - Installiertes Produkt gefunden - Microsoft Visual C# Express 2010
11.07.2012 21:32:22 - Die Erweiterung mit der ID 5862fabf-d5bd-45fc-ba04-64637cbfad2b wird nicht für Microsoft Visual C# Express 2010 installiert.
11.07.2012 21:32:23 - Folgende Zielprodukte wurden ausgewählt...
11.07.2012 21:32:23 -     Microsoft Visual C# Express 2010
11.07.2012 21:32:23 -
11.07.2012 21:32:23 - Die Installation der Erweiterung für Microsoft Visual C# Express 2010 wurde gestartet...
11.07.2012 21:32:24 - Installationsfehler: System.IO.PathTooLongException: C:\Dokumente und Einstellungen\xxx\Lokale Einstellungen\Anwendungsdaten\Microsoft\VCSExpress\10.0\Extensions\Laurent Bugnion (GalaSoft)\MVVM Light Toolkit Templates\4.0.23.0\ItemTemplates\WPF\Mvvm\MvvmViewModelLocator.WPF.zip: MvvmViewModelLocator.WPF.vstemplate
   bei Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.BeginInstall(IInstallableExtension installableExtension, Boolean perMachine, AsyncOperation asyncOp)
   bei Microsoft.VisualStudio.ExtensionManager.ExtensionManagerService.InstallWorker(IInstallableExtension extension, Boolean perMachine, AsyncOperation asyncOp)

 

OS: Win XP (german)

 

thanks in advance for your support!

Mar 1, 2013 at 10:13 PM
I've tried in the last two days to install item templates for MVVM Light into Visual Studio 2012 Premium, with no success.

Version I'm trying to install is 4.1.24.0 using GalaSoft.MvvmLight.4.1.24.0.msi .

I previously tried using nuget with same result.

What am I doing wrong? How can I fix it doing some manual command to put item templates in VS2012 ?
Mar 12, 2013 at 11:37 PM
Same here.
Coordinator
Mar 13, 2013 at 7:07 AM
Hi,

Did you read the readme that automatically opens in your favorite browser after the MSI completes, and run the corresponding VSIX files?

Thanks
Laurent
Sep 25, 2013 at 7:03 AM
This is the first time that I use VSIX files. It did not run when I double clicked on it in Win8. However, when I right clicked on the file, I got the option to choose "Microsoft Visual Studio Version Selector" from the popup menu. I selected it, then it worked and I was then able to find those templates in VS.

I believe the reason so many people asked the same question is that VSIX is not automatically linked to be opened by the Version Selector.

Hope this help a bit.