V4.1 for VS 2010

May 7, 2014 at 11:38 AM
I just wanted to install the V4.1 for 2010 but as I see this Version is only supported for VS2012 and 2013.

There is following comment for the V4.1: If you use Visual Studio 2010, please stay tuned, we will publish an update in a few days with support for VS10.

But I cannot find a Version that supports VS2010. Please can you give me a short response if I can use the V4.1 with VS2010 and if yes where can I find the Installation package?
Coordinator
May 7, 2014 at 11:49 AM
Hi!

Yes I have to admit that this item has slipped a bit. The amount of people who use VS10 seems very small and in fact you are the first one to reach out.

Any reason why you cannot move to VS12? I am not saying I will stop supporting VS10, not at all. Just trying to prioritize items.

Thanks for the help (and understanding)

Cheers
Laurent
May 7, 2014 at 12:04 PM
thanks for the quick response. Yes we want to upgrade to .NET 4.5.1 (VS 2013) as soon as we know that VS 2013 supports the Compact Framework because at the Moment we are developing with VS2008/VS2010 in the embedded systems field with C++/CLI.

Do you think that you can provide a install package for VS 2010 in the next one or two month? We are using MVVM-light V3 and there are some problems with Memory leaks (Messenger, etc.) and no support for the EventToCommand approach. That is why we want to upgrade to V4 as soon as possible.

regards,
Andy
Coordinator
May 7, 2014 at 12:24 PM
Hey!

Yes that should be possible.

Did you also try using Nuget to add the assemblies to a VS10 project? I do understand the advantage of a full installation, but that could be a stopgap solution in the meantime.

Cheers
Laurent
May 7, 2014 at 1:38 PM
ok thank you. I will try to add the assemblies with NuGet in the next days!
regards,
Andy
Sep 26, 2014 at 10:55 PM
Which version should I download for VS2010? thanks
Sep 29, 2014 at 6:43 AM
we use the Nuget package now and it works fine - thanks!