This project has moved and is read-only. For the latest updates, please go here.

Installing MVVMLightLibs removes all other references??

Apr 19, 2016 at 11:55 AM

Maybe a stupid question ;-)

In a fresh new Universal Windows app for Win10 (VS2015 community) all my reference dissapear when I try to install the MVVMLight-Libs through the Nuget program.

I'm talking about Microsoft.AppplicationsInsights; Microsoft.AppplicationsInsights.Persistencechannel; Microsoft.AppplicationsInsights.WindowApps and Microsoft.NETCore.UniversalWindowsPlatform. All are nuget packages
The Universal Windows-references doesn't disappear though.

When removing the MVVMLight-Libs packages all above packages return.

As when the references disappear, i got problems with: The type or namespace name 'System' could not be found (are you missing a using directive or an assembly reference?)

Any ideas?

kind regards,

Apr 19, 2016 at 12:36 PM

It's not a stupid question, but it is also the first time I hear about this. It sounds like a Nuget issue. Is it only with MVVM Light that you see this issue? Can you send me more information about your system? Do you have the latest Nuget version?

I can take it up with the Nuget team, but I think it might be an issue on your machine (I hate to say that...)

Apr 19, 2016 at 3:18 PM
Edited Apr 19, 2016 at 3:33 PM
Hi Laurent,

thanks for the feedback.
I have 3 machines which are configured for programming. I thought I have the issue on all three of them.

I just tried it another way. Installing the reference through the extensions and update.
Then new project =>MVVMLight win10
But then, I have the same problem.
The System-references are gone?

see prtscrn

EDIT: just tried extra things:

New -> Blank app (Universal Windows).
These are current references:

After testing with Nuget Prism MVVM, all other references are kept:

Then removed Prism, situation is again as Situation 1.
through Nuget, added the MVVMLightLibs and all other Nuget packages are gone!

Nuget package manager however, still find them, but my solution doesn't...

kind regards,

Apr 19, 2016 at 3:48 PM
And when you build, the packages are not restored?

I will try this at home and let you know if I can repro.

Apr 19, 2016 at 6:32 PM
I tried your suggestion above already before, but I didn't think it helped.
Now I'm at my pc @home, and here I don't have the reference problem... everything works as expected.

I have a third pc on my work, and i will test it also there tomorrow.

Either way, I will keep you updated!

kind regards,
Apr 20, 2016 at 12:09 PM
Please make sure that you have the latest version of Nuget installed everywhere. The Windows 10 templates uses the new Nuget "features" (not willingly but I have no choice) which is restoring packages when you build the solution. I suspect that you might have an old version of Nuget which fails to restore the packages. That should happen automatically.