Error when using EventToCommand

Apr 13, 2010 at 6:39 PM

I downloaded VS 2010 Premium and started working with that yesterday. I am trying to configure an EventToCommand using DevExpress, which is guess work since they don't have Blend ability. Anyway, I get an error when I try and run:

Error: Could not load file or assembly 'System.Windows.Interactivity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference.

I have tried using the GAC version of the Interactivity assembly as well as the one you provide and I get the same error. Any clues?

<dxn:NavBarControl x:Name="mNavBarControl">

        <dxn:NavBarControl.View>

            <dxn:ExplorerBarView Orientation="Horizontal" ItemsPanelOrientation="Horizontal" ItemVisualStyle="{StaticResource largeImageStyle}">

                <i:Interaction.Triggers>

                    <i:EventTrigger EventName="Click">

                        <gmc:EventToCommand Command="{Binding Command}"/>

                    </i:EventTrigger>

                </i:Interaction.Triggers>

            </dxn:ExplorerBarView>

        </dxn:NavBarControl.View>

    </dxn:NavBarControl>

Coordinator
Apr 13, 2010 at 10:58 PM

Hi,

I downloaded VS10 RTM but didn't install it yet. I plan to do this very soon and will be able to test. The message sounds like there is a version incompatibility (again) with that assembly. More about this later.

Cheers,

Laurent

Coordinator
Apr 18, 2010 at 10:25 PM

For info, after instaling VS10 RTM, all works fine. I cannot explain the issue without additional information.

Cheers,

Laurent