This project has moved and is read-only. For the latest updates, please go here.

SL5 assemblies missing XmlnsDefinition

Feb 2, 2012 at 11:23 PM

We recently upgraded to SL5, but missed our MVVM Light dependencies.  So I tried to upgrade to the SL5 version of MVVM Light (v3 because we can't ship beta level software) and it looks like SL5 assemblies are both missing the XmlnsDefinition attribute.  Our code doesn't compile (we're cross compiling SL5 to WPF4 so we require an XmlnsDefinition; referencing by assembly name will break the cross compile) so we're stuck with the SL4 assemblies for now.

Feb 15, 2012 at 12:17 AM

No reply in almost 2 weeks?  Really?  So the PRISM team is going to beat MVVM Light to SL5?

Feb 15, 2012 at 6:55 AM
Edited Feb 19, 2012 at 10:43 AM

Hey Mike,

I am sorry for the lack of response. The past few weeks have shown an increase activity in my firm with a huge project I am involved with. I am also out conferencing this week and had to find a little time to prepare. But I don't mean to complain :)

Yes you are right about the XmlnsDefinition, it is a regrettable omission. Making the fix will take a very short time, making a new installer and testing will take an evening, and I didn't have one until now (hopefully it will clear a bit soon, hoping to have a fix this weekend).

[update 20120219: Actually XmlnsDefinition is included into the SL5 version too, check my reply below]

I wouldn't wait for the fix though. Open source is a great concept that means that you can download the source and fix it yourself. That's really awesome. In this case, compare the AssemblyInfo to the one in SL4. Let me know if you have any issue and I will do my best to answer faster :)


PS: I would leave my day job and work only on MVVM Light if I could. However people keep sending me bills and insist that I pay them on time. That sucks, I know. Unfortunately the Donation page is very idle, won't be able to leave any time soon ( ;) 

Feb 15, 2012 at 8:00 AM

Update: I was just notified that the donation button is broken. Damn, noone reported THAT bug ;)

Feb 15, 2012 at 2:38 PM

Laurent, thanks for replying.  I appreciate your situation.  Unfortunately my situation is that I work under some onerous rules regarding open source and modifying the source and rebuilding is simply not an option for me.  (Crazy, I know.  But that's what happens when the CMMI yahoos meet up with the security yahoos and they start jointly running the asylum.)  So I'm stuck waiting for an official build. :/


Hope your conferences went off well.

Feb 19, 2012 at 10:41 AM

Hi Mike,

I tried to repro your issue, and I cannot. Here is what I did:

- Checked the code in the Silverlight 5 version of MVVM Light on Codeplex: The XmlnsDefinition attribute is defined correctly.

- Installed MVVM Light V4.0.2.19 from

- Created a new MVVM Light (SL5) application in Visual Studio.

- Opened the solution in Blend 4 preview for Silverlight 5

- Added an EventToCommand to the TextBlock on the main page

- Checked the XAML: The XmlnsDefinition was found and recognized by Blend. The prefix added is: xmlns:Custom="" (which is what I expected).

I am wondering what went wrong in your case. Could it be that, by mistake, you installed V3 instead of V4?

Let me know and let's solve this issue.


Feb 19, 2012 at 3:05 PM

I used the SL5 binaries from this installer:

It's definitely V3.  V4 is not an option for us because it's still in beta.

Feb 19, 2012 at 4:17 PM

Something does not compute here. V3 never had XmlnsDefinition. It is a feature I added in V4. You must have used V4 at some point.

That said, I can add XmlnsDefinition to V3 in order to solve your issues. I must finish something else first but I should be able to do that either tonight or tomorrow.



Feb 20, 2012 at 9:29 PM

Hi Mike,

Please download the new DLLs from!1110&parid=40CFFDE85F1AB56A!129&authkey=!AJ738Uba7ZhZZ1c

Download the MVVMLight_V3.0.20 package.

Extract this locally and copy the DLLs (either from Debug or Release) into your C:\Program Files (x86)\Laurent Bugnion (GalaSoft)\Mvvm Light Toolkit\Binaries folder. Then please test it out and let me know if that fixes your issue.

If the test works fine, I will create a new installer.